Minggu, 17 Oktober 2010

linux 1

 how to connect the network card in linux using 2 network cards
root@alk.root#ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:EE:71:11
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:feee:7111/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:61 errors:0 dropped:0 overruns:0 frame:0
          TX packets:85 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6938 (6.7 KiB)  TX bytes:10092 (9.8 KiB)
          Interrupt:10 Base address:0×1080
eth1    Link encap:Ethernet  HWaddr 00:0C:29:EE:71:1B
          inet addr:192.168.100.1  Bcast:192.168.100.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:feee:711b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:1796 (1.7 KiB)
          Interrupt:9 Base address:0×1400

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:35 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0

Ethernet Standards

Add caption

Command Output Showing MAC Address Table Learning (Continued)

Switch1# show mac-address-table dynamic
Mac Address Table
------------------------------------------
Vlan Mac Address Type Ports
---- ----------- ---- -----
1 000f.2343.87cd DYNAMIC Fa0/13
1 0200.3333.3333 DYNAMIC Fa0/3
1 0200.4444.4444 DYNAMIC Fa0/13
Total Mac Addresses for this criterion: 3
! Above, Switch1’s MAC address table lists three dynamically learned addresses,
! including Switch4’s FA 0/13 MAC.
! Below, Switch1 pings Switch4’s management IP address.
Switch1# ping 10.1.1.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
! Below Switch1 now knows the MAC address associated with Switch4’s management IP
! address. Each switch has a range of reserved MAC addresses, with the first MAC
! being used by the switch IP address, and the rest being assigned in sequence to
! the switch interfaces – note 0xcd (last byte of 2nd address in the table above)
! is for Switch4’s FA 0/13 interface, and is 13 (decimal) larger than Switch4’s
! base MAC address.
Switch1# show mac-address-table dynamic
Mac Address Table
------------------------------------------
Vlan Mac Address Type Ports
---- ----------- ---- -----
1 000f.2343.87c0 DYNAMIC Fa0/13
1 000f.2343.87cd DYNAMIC Fa0/13
1 0200.3333.3333 DYNAMIC Fa0/3
1 0200.4444.4444 DYNAMIC Fa0/13
Total Mac Addresses for this criterion: 4
! Not shown: PC1 ping 10.1.1.23 (R3) PC1's MAC in its MAC address table
------------------------------------------
Vlan Mac Address Type Ports
---- ----------- ---- -----
1 000f.2343.87c0 DYNAMIC Fa0/13
1 000f.2343.87cd DYNAMIC Fa0/13
1 0010.a49b.6111 DYNAMIC Fa0/13
1 0200.3333.3333 DYNAMIC Fa0/3
1 0200.4444.4444 DYNAMIC Fa0/13
Total Mac Addresses for this criterion: 5
! Above, Switch1 learned the PC’s MAC address, associated with FA 0/13,
! because the frames sent by the PC came into Switch1 over its FA 0/13.
! Below, Switch4’s MAC address table shows PC1’s MAC off its FA 0/6
switch4# show mac-address-table dynamic
Mac Address Table
-------------------------------------------
Vlan Mac Address Type Ports
---- ----------- -------- -----
1 000a.b7dc.b780 DYNAMIC Fa0/13
1 000a.b7dc.b78d DYNAMIC Fa0/13
1 0010.a49b.6111 DYNAMIC Fa0/6
1 0200.3333.3333 DYNAMIC Fa0/13
1 0200.4444.4444 DYNAMIC Fa0/4
Total Mac Addresses for this criterion: 5
! Below, for example, the aging timeout (default 300 seconds) is shown, followed
! by a command just listing the mac address table entry for a single address.
switch4# show mac-address-table aging-time
Vlan Aging Time
---- ----------
1 300
switch4# show mac-address-table address 0200.3333.3333
Mac Address Table
-------------------------------------------
Vlan Mac Address Type Ports
---- ----------- -------- -----
1 0200.3333.3333 DYNAMIC Fa0/13
Total Mac Addresses for this criterion: 1

Configurasi Router

Router(config)#interface serial 0/1/0
Router(config-if)#ip address 172.16.1.1 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#clock rate 9600
Router(config-if)#exit
Router(config)#interface fasethernet 0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router 0 :
Router > enable
Router#conf t
Router(config)#interface serial 0/1/0
Router(config-if)#ip address 172.16.1.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial 0/1/1
Router(config-if)#ip address 172.16.0.1 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#clock rate 9600
Router(config-if)#exit
Router(config)#interface fasethernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router 1 :
Router > enable
Router#conf t
Router(config)#interface serial 0/1/0
Router(config-if)#ip address 172.16.0.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fasethernet 0/0
Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fasethernet 0/1
Router(config-if)#ip address 10.0.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

Sabtu, 16 Oktober 2010

IPV4 & IPV6 MIGRATION


http://www.facebook.com/photo.php?fbid=449457788918&set=t.190010265716&pid=5302858&id=517093918

Securing Your Nameserver

Securing Your Nameserver


BIND 8 and 9 support a wide variety of security mechanisms. These features are particularly important if your nameserver is running on the Internet, but they're also useful on purely internal nameservers.
We'll start by discussing measures you should take on all nameservers for which security is important. Then we'll describe a model in which your nameservers are split into two communities, one for serving only resolvers and one for answering other nameservers' queries.

BIND Version


One of the most important ways you can enhance the security of your nameserver is to run a recent version of BIND. All versions of BIND 8 before 8.4.7 and all versions of BIND 9 older than 9.3.2 are susceptible to at least a few known attacks. Check the ISC's list of vulnerabilities in various BIND versions at http://www.isc.org/sw/bind/bind-security.php for updates.
But don't stop there: new attacks are being thought up all the time, so you'll have to do your best to keep abreast of BIND's vulnerabilities and the latest "safe" version of BIND. One good way to do that is to read the comp.protocols.dns.bind newsgroup or its mailing list equivalent, bind-users, regularly. If you'd prefer less noise, there's always the bind-announce mailing list, which carries only announcements of patches and new releases of BIND.[*]
[*] We described how to subscribe to bind-users back in Chapter 3. To subscribe to bind-announce, the instructions are the same.
There's another aspect of BIND's version relevant to security: if a hacker can easily find out which version of BIND you're running, he may be able to tailor his attacks to that version of BIND. And, wouldn't you know it, since about BIND 4.9, BIND nameservers have replied to a certain query with their version. If you look up TXT records in the CHAOSNET class attached to the domain name version.bind, BIND graciously returns something like this:
% dig txt chaos version.bind.

; <<>> DiG 9.3.2 <<>> txt chaos version.bind.
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14286
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;version.bind.                  CH      TXT

;; ANSWER SECTION:
version.bind.           0       CH      TXT     "9.3.2"

;; AUTHORITY SECTION:
version.bind.           0       CH      NS      version.bind.

;; Query time: 17 msec
;; SERVER: 192.168.0.1#53(192.168.0.1)
;; WHEN: Sat Jan  7 16:14:39 2006
;; MSG SIZE  rcvd: 62

To address this, BIND versions 8.2 and later let you tailor your nameserver's response to the version.bind query:
options {
    version "None of your business";
};

CCNA4

R1 dhcp

ip dhcp excluded-address 1.1.1.1 1.1.1.10
!
ip dhcp pool PHONE
network 1.0.0.0 255.0.0.0
default-router 1.1.1.1
option 150 ip 1.1.1.1

interface FastEthernet0/1
ip address 1.1.1.1 255.0.0.0
duplex auto
speed auto

interface Serial0/0
ip address 200.200.200.2 255.255.255.252

interface Serial0/1
bandwidth 64000
ip address 222.0.0.2 255.255.255.248
ip helper-address 222.0.0.2
encapsulation frame-relay
frame-relay interface-dlci 222

router rip
version 2
network 1.0.0.0
network 200.200.200.0
network 222.0.0.0
no auto-summary

line con 0
password 7 0831441E074A
login
line vty 0 4
login





R2 dhcp

ip dhcp excluded-address 2.2.2.1 2.2.2.10
!
ip dhcp pool PHONE-2
network 2.0.0.0 255.0.0.0
default-router 2.2.2.1
option 150 ip 2.2.2.1

interface FastEthernet0/0
ip address 2.2.2.1 255.0.0.0
duplex auto
speed auto

interface Serial0/0
ip address 200.200.200.1 255.255.255.252
clock rate 4000000
!
interface Serial0/1
bandwidth 64000
ip address 222.0.0.1 255.255.255.248
ip helper-address 222.0.0.1
encapsulation frame-relay
frame-relay interface-dlci 111

router rip
version 2
network 2.0.0.0
network 200.200.200.0
network 222.0.0.0
no auto-summary

line con 0
password 7 0872425A5A0B
login
line vty 0 4
login





ISP (router)

ip dhcp excluded-address 44.44.44.1 44.44.44.44

ip dhcp pool eni$$
network 44.44.44.0 255.255.255.0
default-router 44.44.44.1
dns-server 44.44.44.44

username ene password 0 11111

interface FastEthernet0/0
ip address 44.44.44.1 255.255.255.0
duplex auto
speed auto

interface FastEthernet0/1
ip address 203.1.1.1 255.255.255.0
ip helper-address 203.1.1.10
duplex auto
speed auto

interface Serial0/0
bandwidth 64000
ip address 222.0.0.3 255.255.255.248
ip helper-address 222.0.0.3
encapsulation frame-relay
frame-relay interface-dlci 333
frame-relay interface-dlci 444

interface Serial0/1
ip address 200.200.200.5 255.255.255.252
ip helper-address 200.200.200.5
clock rate 250000

router rip
version 2
network 44.0.0.0
network 200.200.200.0
network 203.1.1.0
network 222.0.0.0
no auto-summary

snmp-server community SNMP RW

line con 0
line vty 0 4
login



SA-Route

interface FastEthernet0/0
ip address 205.1.1.1 255.255.255.0
duplex auto
speed auto

interface Serial0/0
ip address 200.200.200.6 255.255.255.252

router rip
version 2
network 200.200.200.0
network 205.1.1.0
no auto-summary

line con 0
line vty 0 4
login

Troubleshooting PPP Configuration

Task 1: Load Routers with the Supplied Scripts
R1
enable
configure terminal
!
hostname R1
!
!
enable secret class
!
!
!
no ip domain lookup
!
username R2 password 0 cisco
!
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.128
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
duplex auto
speed auto
!

Troubleshooting Enterprise Networks 1

Task 1: Load Routers with the Supplied Scripts
!------------------------------------------
! R1
!------------------------------------------
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
security passwords min-length 6
enable secret 5 ciscoccna
!
ip cef
!
ip dhcp pool Access1
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
!
no ip domain lookup
!
username R3 password 0 ciscoccna
username ccna password 0 ciscoccna
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain RIP_KEY
no shutdown
!
interface FastEthernet0/1
ip address 192.168.11.1 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain RIP_KEY
no shutdown
!

Basic EIGRP Configuration Lab

 Enable EIGRP routing on the R2 router using the router eigrp command.
R1(config)#router eigrp 1
R1(config-router)#
R1(config-router)#network 172.16.0.0
R1(config-router)#
 
  255.255.255.255
– 255.255.255.252 Subtract the subnet mask
-------------------
0. 0. 0. 3 Wildcard mask

R1(config-router)# network 192.168.10.4 0.0.0.3
R1(config-router)#end

Configure EIGRP on the R2 and R3 Routers.
R2(config)#router eigrp 1
R2(config-router)#network 172.16.0.0
R2(config-router)#network 192.168.10.8 0.0.0.3
R2(config-router)#end


Configure EIGRP on the R3 router using the router eigrp and network commands.

R3(config)#router eigrp 1
R3(config-router)#network 192.168.1.0
R3(config-router)#network 192.168.10.4 0.0.0.3
R3(config-router)#
R3(config-router)#end

OSPF Troubleshooting Lab

Step 1: Load the following script onto the Branch1 router:
 
hostname Branch1
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 10.10.4.1 255.255.254.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 172.16.7.2 255.255.255.252
no shutdown
!
interface Serial0/0/1
ip address 172.16.7.9 255.255.255.252
no shutdown
!
router ospf 2
passive-interface FastEthernet0/0
network 10.10.4.0 0.0.1.255 area 0
network 172.16.7.0 0.0.0.3 area 0
network 172.16.7.8 0.0.0.3 area 0
!
ip classless
!
line con 0
line vty 0 4
login
!
!
end
 
Step 2: Load the following script onto the Branch2 router.
hostname Branch2
!
!
!
interface FastEthernet0/0
ip address 10.10.6.1 255.255.254.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 172.16.7.10 255.255.255.252
clock rate 64000
no shutdown
!
interface Serial0/0/1
ip address 172.16.7.6 255.255.255.252
!
router ospf 1
log-adjacency-changes
passive-interface Serial0/0/1
network 172.16.7.4 0.0.0.3 area 0
network 172.16.7.8 0.0.0.3 area 0
network 10.10.6.0 0.0.3.255 area 0
!
ip classless
!
line con 0
line vty 0 4
login
!
!
end

Step 3: Load the following script onto the HQ router.
 
hostname HQ
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.252.0
duplex auto
speed auto
no shutdown
!
!
interface Serial0/0/0
ip address 172.16.7.1 255.255.255.252
no shutdown
!
interface Serial0/0/1
ip address 172.16.7.5 255.255.255.252
clock rate 64000
no shutdown
!
interface Loopback1
ip address 209.165.202.129 255.255.255.252
!
router ospf 1
log-adjacency-changes
passive-interface FastEthernet0/0
passive-interface Loopback1
network 172.16.7.0 0.0.0.3 area 0
network 172.16.7.4 0.0.0.3 area 0
network 10.10.0.0 0.0.7.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 loopback1
!
line con 0
line vty 0 4
login
!
!
end

Chapter 2: Communications over the Networks

1
Which two layers of the OSI model have the same functions as the TCP/IP model Network Access Layer? (Choose two.)
Network
Transport
* Physical
* Data Link
Session

2
What is a primary function of the trailer information added by the data link layer encapsulation?
* supports error detection
ensures ordered arrival of data
provides delivery to correct destination
identifies the devices on the local network
assists intermediary devices with processing and path selection

3
During the encapsulation process, what occurs at the data link layer?
No address is added.
The logical address is added.
* The physical address is added.
The process port number is added.

4
What device is considered an intermediary device?
file server
IP phone
laptop
printer
* switch

5
Which layer encapsulates the segment into packets?
physical
* data link
network
transport

6
Which statements correctly identify the role of intermediary devices in the network? (Choose three.)
* determine pathways for data
initiate data communications
* retime and retransmit data signals
originate the flow of data
* manage data flows
final termination point for data flow

7
What can be identified by examining the network layer header?
the destination device on the local media
* the path to use to reach the destination host
the bits that will be transferred over the media
the source application or process creating the data

8
What is the proper order of the layers of the OSI model from the highest layer to the lowest layer?
physical, network, application, data link, presentation, session, transport
application, physical, session, transport, network, data link, presentation
application, presentation, physical, session, data link, transport, network
* application, presentation, session, transport, network, data link, physical
presentation, data link, session, transport, network, physical, application

9
Refer to the exhibit. Which three labels correctly identify the network types for the network segments that are shown? (Choose three.)
Network A -- WAN
* Network B -- WAN
* Network C -- LAN
Network B -- MAN
Network C -- WAN
* Network A -- LAN

10
What are the key functions of encapsulation? (Choose three.)
allows modification of the original data before transmission
* identifies pieces of data as part of the same communication
enables consistent network paths for communication
* ensures that data pieces can be directed to the correct receiving end device
* enables the reassembly of complete messages
tracks delay between end devices

11
Refer to the exhibit. Which networking term describes the data interleaving process represented in the graphic?
piping
PDU
streaming
multiplexing
* encapsulation

12
What is a PDU?
corruption of a frame during transmission
data reassembled at the destination
retransmitted packets due to lost communication
* a layer specific encapsulation

13
Refer to the exhibit. "Cell A" at IP address 10.0.0.34 has established an IP session with "IP Phone 1" at IP address 172.16.1.103. Based upon the graphic, which device type best describes the function of wireless device "Cell A?"
the destination device
* an end device
an intermediate device
a media device

14
Refer to the exhibit. Which set of devices contains only end devices?
A, C, D
B, E, G, H
C, D, G, H, I, J
D, E, F, H, I, J
* E, F, H, I, J

15
Refer to the exhibit. Which term correctly identifies the device type that is included in the green area?
source
end
transfer
* intermediary

16
Which three statements best describe a Local Area Network (LAN)? (Choose three.)
* A LAN is usually in a single geographical area.
* The network is administered by a single organization.
The connection between segments in the LAN is usually through a leased connection.
The security and access control of the network are controlled by a service provider.
* A LAN provides network services and access to applications for users within a common organization.
Each end of the network is generally connected to a Telecommunication Service Provider (TSP).

17
Refer to the exhibit. What type of network is shown?
WAN
MAN
* LAN
WLAN

18
What is the purpose of the TCP/IP Network Access layer?
path determination and packet switching
* data representation, encoding, and control
reliability, flow control, and error detection
detailing the components that make up the physical link and how to access it
the division of segments into packets

19
Which characteristic correctly refers to end devices in a network?
manage data flows
originate data flow
* retime and retransmit data signals
determine pathways for data

20
What is the primary purpose of Layer 4 port assignment?
to identify devices on the local media
to identify the hops between source and destination
to identify to the intermediary devices the best path through the network
to identify the source and destination end devices that are communicating
* to identify the processes or services that are communicating within the end devices

21
Select the statements that are correct concerning network protocols. (Choose three.)
* define the structure of layer specific PDU's
dictate how to accomplish layer functions
* outline the functions necessary for communications between layers
limit hardware compatibility
* require layer dependent encapsulations
eliminate standardization among vendors

Jumat, 15 Oktober 2010

CCNA v4 - E2 - Module 4(100%)

1. A network administrator is evaluating RIP versus EIGRP for a new network. The network will be sensitive to congestion and must respond quickly to topology changes. What are two good reasons to choose EIGRP instead of RIP in this case? (Choose two.)

EIGRP only updates affected neighbors.
EIGRP updates are partial.

2. Which event will cause a triggered update?

a route is installed in the routing table

3. Refer to the exhibit. If all routers are using RIP, how many rounds of updates will occur before all routers know all networks?

3

4. Refer to the exhibit. The routers in this network are running RIP. Router A has not received an update from Router B in over three minutes. How will Router A respond?

The Invalid timer will mark the route as unusable if an update has not been received in 180 seconds.

5. The graphic shows a network that is configured to use RIP routing protocol. Router2 detects that the link to Router1 has gone down. It then advertises the network for this link with a hop count metric of 16. Which routing loop prevention mechanism is in effect?

CCNA v4 - E4 - Module 3 (100%)

1. Which best describes the benefit of using Frame Relay as opposed to a leased line or ISDN service?

Customers only pay for the local loop and the bandwidth they purchase from the network provider.

2. Which statement about Frame Relay subinterfaces is correct?

Point-to-point subinterfaces act like leased lines and eliminate split-horizon routing issues.

3. What best describes the use of a data-link connection identifier (DLCI)?

locally significant address used to identify a virtual circuit

4. What is created between two DTEs in a Frame Relay network?

virtual circuit

5. Which two items allow the router to map data link layer addresses to network layer addresses in a Frame Relay network? (Choose two.)

Inverse ARP
LMI status messages

CCNA v4 - E2 - Module 2(97%)

1. A router has one static route configured to each destination network. Which two scenarios would require an administrator to alter the static routes that are configured on that router? (Choose two.)

The destination network is moved to a different interface on the same router.
A topology change occurs where the existing next-hop address or exit interface is not accessible.

2. Which of the following is true regarding CDP and the graphic shown?

By default, Router A will receive CDP advertisements from routers B and C.

3. What happens to a static route entry in a routing table when the outgoing interface is not available?

The route is removed from the table.

4. What two devices are responsible for converting the data from the WAN service provider into a form acceptable by the router? (Choose two).

a modem
a CSU/DSU device

5. Refer to the exhibit. A company network engineer is assigned to establish connectivity between the two Ethernet networks so that hosts on the 10.1.1.0/24 subnet can contact hosts on the 10.1.2.0/24 subnet. The engineer has been told to use only static routing for these company routers. Which set of commands will establish connectivity between the two Ethernet networks?

R1(config)# ip route 10.1.1.0 255.255.255.0 192.168.0.2
R2(config)# ip route 10.1.2.0 255.255.255.0 192.168.0.1

CCNA v4 - E4 - Module 1 (100%)

1. Which statement about WAN protocols is correct?

Most WAN protocols use HDLC or a variant of HDLC as a framing mechanism.

2. Which statement is true of the functionality of the layers in the hierarchical network model?

The distribution layer aggregates WAN connections at the edge of the campus.

3. Which WAN technology uses a fixed payload of 48 bytes and is transported across both switched and permanent virtual circuits?

ATM

4. A U.S. company requires a WAN connection used only to transfer sales data from individual stores to the home office. All transfers will occur after business hours. The required bandwidth for this connection is estimated to be less than 38 kbps. Which type of connection requires the least investment for this company?

analog dialup

5. What is an advantage of packet-switched technology over circuit-switched technology?

Packet-switched networks can efficiently use multiple routes inside a service provider network.

6. Which statement is true about data connectivity between a customer and a service provider?

The segment between the demarcation point and the central office is known as the "last mile."

7. What are two advantages of an analog PSTN WAN connection? (Choose two.)

low cost
availability

8. What can cause a reduction in available bandwidth on a cable broadband connection?

number of subscribers

9. For digital lines, which device is used to establish the communications link between the customer equipment and the local loop?

CSU/DSU

10. At which two layers of the OSI model does a WAN operate? (Choose two.)

Physical Layer
Data Link Layer

11. A company needs a WAN connection that is capable of transferring voice, video, and data at a minimum data rate of 155 Mbps. Which WAN connection is the best choice?

ATM

12. Which statement is true about the differences between a WAN and a LAN?

A WAN often relies on the services of carriers, such as telephone or cable companies, but a LAN does not.

13. Which networking device is typically used to concentrate the dial-in and dial-out traffic of multiple users to and from a network?

access server

14. Why is the call setup time of a circuit-switched WAN implementation considered a drawback?

Data cannot be transferred until a circuit has been established.

15. What three terms are associated with ISDN PRI? (Choose three.)

circuit switching
data bearer channels
time-division multiplexing

16. Which three features are identified with Frame Relay connections? (Choose three.)
CIR
DLCI
PVC

17. Which two devices are commonly used as data communications equipment? (Choose two.)

modem
CSU/DSU

18. Which packet-switched WAN technology offers high-bandwidth connectivity capable of managing data, voice, and video all on the same infrastructure?

metro Ethernet

19. Which three WAN devices can be found in the cloud? (Choose three.)

ATM switches
core routers
Frame Relay switches

20. Which switching type will allow the communication devices in the provider network to be shared and only allocated to an individual subscriber during data transfer?

dedicated switched lines

21. What type of connectivity is established when VPNs are used from the remote site to the private network?

tunnels

22. Which term describes a device that will put data on the local loop?

DCE

Downloading and Installing Cisco myPlanNet

 
Downloading and installing Cisco myPlanNet is easy to do. This quick video walks through how to get the game and install it on your PC. (The download is approximately 40MB) To download and start playing the game, please visit


Routers A and B run RIP with each other, and Routers A and C run BGP with each
other. If you want Router A to redistribute routes from 170.10.0.0 with a metric of 2 and to
redistribute all other routes with a metric of 5, use the following commands for Router A:

!Router A
router rip
network 3.0.0.0
network 2.0.0.0
network 150.10.0.0
passive-interface serial 0
redistribute bgp 100 route-map SETMETRIC
!
router bgp 100
neighbor 2.2.2.3 remote-as 300
network 150.10.0.0
!
route-map SETMETRIC permit 10
match ip-address 1
set metric 2
!
route-map SETMETRIC permit 20
set metric 5
!
access-list 1 permit 170.10.0.0 0.0.255.255


When a route matches the IP address 170.10.0.0, it is redistributed with a metric of 2. When a route does not match the IP address 170.10.0.0, its metric is set to 5, and the route is redistributed.Assume that on Router C you want to set to 300 the community attribute of outgoing updates for network 170.10.0.0. The following commands apply a route map to outgoing updates on Router C:

!Router C
router bgp 300
network 170.10.0.0
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 route-map SETCOMMUNITY out
!
route-map SETCOMMUNITY permit 10
match ip address 1
set community 300
!
access-list 1 permit 0.0.0.0 255.255.255.255
 
Access list 1 denies any update for network 170.10.0.0 and permits updates for any other network.

Point-to-MultiPoint Mode

Point-to-MultiPoint networks have been designed to work simply and naturally when faced with partial mesh connectivity. In Point-to-MultiPoint mode, OSPF treats all router-to-router connections over the non-broadcast network as if they were point-to-point links. No Designated Router is elected
for the network, nor is there an LSA generated for the network. It may be necessary to configure the
set of neighbors that are directly reachable over the Point-to-MultiPoint network. Each neighbor
is identified by its IP address on the Point-to-MultiPoint network. Because no Designated Routers
are elected on Point-to-MultiPoint networks, the Designated Router eligibility of configured
neighbors is undefined.Alternatively, neighbors on Point-to-MultiPoint networks may be dynamically discovered by
lower-level protocols such as Inverse ARP. In contrast to NBMA networks, Point-to-MultiPoint
networks have the following properties:

1.Backup Designated Router for a Point-to-MultiPoint network. No network-LSA is originated for
   Point-to-MultiPoint networks. Router Priority is not configured for Point-to-MultiPoint
   interfaces, nor for neighbors on Point-to-MultiPoint networks.

2. When originating a router-LSA, Point-to-MultiPoint interface is reported as a collection of
    “point-to-point links” to all of the interface’s adjacent neighbors, together with a single stub link
    advertising the interface’s IP address with a cost of 0.

3. When flooding out a non-broadcast interface (when either in NBMA or Point-to-
    MultiPoint mode) the Link State Update or Link State Acknowledgment packet must be
    replicated in order to be sent to each of the interface’s neighbors.

The following is an example of point-to-multipoint configuration on a NBMA (Frame Relay in this
case) network. Attached is the resulting routing table and Router Link state along with other
pertinent information:

interface Ethernet0
ip address 130.10.6.1 255.255.255.0
!
interface Serial0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
ip address 130.10.10.3 255.255.255.0
ip ospf network point-to-multipoint
ip ospf priority 10
frame-relay map ip 130.10.10.1 140 broadcast
frame-relay map ip 130.10.10.2 150 broadcast
!
router ospf 2
network 130.10.10.0 0.0.0.255 area 0
network 130.10.6.0 0.0.0.255 area 1
R6#sh ip ospf int s 0.1
Serial0.1 is up, line protocol is up
Internet Address 130.10.10.3/24, Area 0
Process ID 2, Router ID 140.10.1.1, Network Type POINT_TO_MULTIPOINT, Cost: 6,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:18
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 130.10.10.2
Adjacent with neighbor 130.10.5.129
R6#sh ip ospf ne
Neighbor ID PriStateDead Time Address Interface
130.10.10.20FULL/ 00:01:37130.10.10.2 Serial0.1
130.10.5.129 0FULL/ -00:01:53 130.10.10.1 Serial0.1
R6#
R6#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route
Gateway of last resort is not set
130.10.0.0/16 is variably subnetted, 9 subnets, 3 masks
O130.10.10.2/32 [110/64] via 130.10.10.2, 00:03:28, Serial0.1
C130.10.10.0/24 is directly connected, Serial0.1
O130.10.10.1/32 [110/64] via 130.10.10.1, 00:03:28, Serial0.1
O IA130.10.0.0/22 [110/74] via 130.10.10.1, 00:03:28, Serial0.1
O130.10.4.0/24 [110/74] via 130.10.10.2, 00:03:28, Serial0.1
C130.10.6.0/24 is directly connected, Ethernet0
R6#sh ip ospf data router 140.10.1.1
OSPF Router with ID (140.10.1.1) (Process ID 2)
Router Link States (Area 0)
LS age: 806

Options: (No TOS-capability)
LS Type: Router Links
Link State ID: 140.10.1.1
Advertising Router: 140.10.1.1
LS Seq Number: 80000009
Checksum: 0x42C1
Length: 60
Area Border Router
Number of Links: 3
Link connected to: another Router (point-to-point)
(Link ID) Neighboring Router ID: 130.10.10.2
(Link Data) Router Interface address: 130.10.10.3
Number of TOS metrics: 0
TOS 0 Metrics: 64
Link connected to: another Router (point-to-point)
(Link ID) Neighboring Router ID: 130.10.5.129
(Link Data) Router Interface address: 130.10.10.3
Number of TOS metrics: 0
TOS 0 Metrics: 64
Link connected to: a Stub Network
(Link ID) Network/subnet number: 130.10.10.3
(Link Data) Network Mask: 255.255.255.255
Number of TOS metrics: 0
TOS 0 Metrics: 0

Using VLAN Database Mode

switch#vlan database   //enter vlan database mode

switch(vlan)#vlan 4 name sales  // creates VLAN  dan names it sales.

switch(vlan)#vlan 10  //creates VLAN 10 and gives it a name of VLAN0010 as a default

switch(vlan)#apply  //applies changes to the VLAN database and increases the revision number by 1

switch(vlan)#exit